One proposal for mORMot 2.
What if we renamed the
RawUTF8 type into
With a default compatibility redirection if
PUREMORMOT2 is not defined, of course.
The "Raw" prefix came from early mORMot code, which used TRichView as reference for the UTF-8 encoding... but it is clearly an overhead today. And "Utf8" is shorter than "String" and "Utf8String" anyway....
What do you think? Feedback is welcome on our forum, as usual.